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GID environment

 GID is a general-purpose
— Must be configurated for each solver
— Solver do not need be modified

* Problem type Preprocess Postroces

— Configuration is done by a set of files, called
problem type

GiD

Problem type defines:

Conditions

Materials j SOLVER j
General data INPUT OUTPUT
Unit systems FILE FILE
Symbols

Format of the input file for the solver
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Classic problem type (deprecated)

« QOrganization

Preprocess GID

Tcl extension files

Configuration files

XML-based configuration ™ D : Extensions to GiD written in the Tcl/Tk
programming language

Conditions definitions
Materials properties e D Command execution files

Problem and intervals data [ 2 i — ; Operating system shell that executes
the analysis process

Units Systems

CO n d |t| ons Sym bo | S Results file Postprocess Postprocess mesh files (oid format)

mesh file

Symbols geometrical definitions o v ﬁ N
(L (=] [

project_name.flavia bon

Te m p | at e fi I eS project :name flaviares |  project_name.flavia.msh D project_name flavia, dat
.bas - Information for the data input file

*»** has -2 Information for additional files
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New problem type system

« Available from the 13th version of GID
« Classic problem type is still supported by GID, but it is considered deprecated

 New organization:

Programming languages:

New problem type « XML
: : .. « XPATH
.spd Main configuration file of the data tree. . TCL/TK
tcl Main TCL file, initialization.
scripts/**.tcl Output description to the file of analysis. Auxiliary libraries:
q Condit definiti « Customlib
.cn onditions definition. . TDOM

J‘;'-a TECGRAF 6 PUC

PUC-RIO



GiD2GeMA problem type

@C

GiD2GeMA

 GID2GeMA is a problem type for GeMA (Geo Modeling Analysis) framework
« This application was developed to preprocess and run models

 Official versions: https://git.tecgraf.puc-rio.br/gema/GiD2GeMA.qgid/-/releases
« Support for 2D and 3D models

* For more information about versions, see “CHANGELOG.log” file
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https://git.tecgraf.puc-rio.br/gema/GiD2GeMA.gid/-/releases
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How to Install

1. Put the set of folders and files 2. Copy “GiD2GeMA.gid” folder to GID

iInside a folder named as problem types folder.
“‘GiD2GeMA.gid”

It depends on your GiD version and its installation
exec ) directory. For example, for GiD version 14.0.5 with
help default installation directory:
images “C:\Program Files\GiD\GID 14.0.5\problemtypes”

scripts

xml
r=| CHANGELOG.md
GeMA bat — ‘ GiD2GeMA.gid
| ] GeMA.cnd
&) GeMA.cl
2] GeMAxml
| | GeMA_default.spd

-
xm| README.md ‘ﬁ‘

3. Restart GID program
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What’s new In this version
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What’s new In this version

Version 1.1.0 - 2021-07-03

 Changed
— Visual identity update.
— Embedded GeMA upgraded to version 1.4.0 revision 3614.

See the CHANGELOG for more information. ﬁ
11 PURQ
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https://git.tecgraf.puc-rio.br/gema/GiD2GeMA.gid/-/blob/master/CHANGELOG.md

2D mechanical example
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Definitions

F F

T Young’s modulus, E ~ 3.00E+07 kPa
Poisson’s ratio, v 0.20 -

~ Applied load, F 100 KN

Length, L 1.0 m

Thickness, t 0.1 m
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Problem Type and model info

1. Set the problem type

a) Inthe GiD menu, select “Data >
Problem type > GiD2GeMA” option.

Data Mesh Calculate Help

Load...
Unload
Debugger...

. Internet retrieve...

$ | » ansys535 gl |ig
Calt '
Conditions Qe =
r % Examples
Viatenials __ Fluent
lnter\.'_al data [@ GiD2GeMA II -
[g Problcfﬁ data n OpenFoam
Data units 3 SAP2000
Local axes 5 Transform...

2. Set model info

a) Inthe tree data, doble-click on “Mechanical > Info > General
> 2D analysis type” field. Select “Plane stress” in the drop-

down list

Q

%
v & Mechanical
[ Dimension: 2D

'%"0Infu

- v [ General

GeMA

bl ~[J Description: Model generated with GiD-GeMA

[ T

-

“[J Plane strain
. pEHE

b I~ Mate Axisymmetric

- D Parts

Remark: To learn how create the geometry and the mesh, see “Help > Tutorials...” in GiD menu.

‘l* TECGRAF

PUC-RIO

14

PUC




Material definition

3. Set the material

a) Open “Mechanical > Materials” folder in the data
tree. Right click on “Material” and select “Rename”
to change the material name to “Concrete”.

'ierf_'.MateriaIs

INY  Moterial
@ Parts
‘%"""I;]Ei-:mrhdalrg,r con
| - A\ Fixed displ
}Concentrat
5 [11 Pressure or

(3 Copy

Import/export materials

b View this

b) Double-clik on material name “Concrete”.

'iirl,f_'.gaterials
b
i @Parts
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c) On theresulting window, select the material type.

A

Rock
[Material type: - Select an option -
' 0K

X Cancel

d) Complete the fields and click on “OK” button

Concrete
Material type:  elastic -
Elastic modulus: 3e7 kPa hd
Poisson ratio: 0.2

+ 0K K Cancel
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Material assignment

4. Assign material

a) Inthe tree data, doble-click on Double-click on
“Mechanical > Parts”.

E . L " (LA R RL LY
. 9| Materials

b @ Concrete
T e

V “BJBoundary conditions

b) On the resulting window, select the material name
on the drop-down list and type the thickness.

pply Parts
Material: Concrete -
Thickness: 0.1 - m -

Group: ¥ % Select
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c) Click on the “Select” button and select the
surfaces to apply these properties.

pply Parts
Material: Concrete -

Thickness: 0.1 m -

X Cance

= >

L.
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Material assignment

4. Assign material

d) Click on the “End” button to finish the selection.

Apply Parts

Material: ‘Concrete

]
0.1 mm ]'

Thickness:

Group: ‘Pa rts Autol

| «/ 0K || X Cancel

e) Rename the group and click on “OK” button.

pply Parts
Material: Concrete -
Thickness: 0.1 Im v

Group: Concrete| - ¥ %, Select

‘[ /0K | X Cancel
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f) To check the assignment, right-click on
“Mechanical > Parts > group: Concrete” in the data
tree. Select “Draw... > Draw groups”

v @© Parts
B4 ° group: Concrete
() Material: Concrete
: () Thickness: 0.1 m
v "B Boundary conditions
L A\ Fixed displacement
- | Concentrated loads
- 1] Pressure on lines
- b Solver options
b I Units

L..

17

D Copy and apply to entities

D Apply more

[ Edit

X Unassign group

D View group in groups window

&9 Draw symbols

4 Change position
8= List entities

4 ” Draw values
&9 Draw all symbols

D View this

v uAuto change render

v 0Auto hide surfaces

Then

Click
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Fixed displacement

5. Assign fixed displacement

a) Doble-click on the “Mechanical > Boundary
conditions > Fixed displacement” condition.

Vz""l;]Boundar)rconditions
SRS  Fixed displacement [+

-~ } Concentrated loads
¢ ¢ [T]Pressure on lines
I - Cnhrar Antinne

b) On the resulting window, select fixed displacement
in x direction. Click on “Select” button.

Apply Fixed displacement

X Fixed displacement x - 1

Fixed displacement y

Ux: 0
IS
lines

Group:

J-‘.- TECGRAF
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c) Select the bottom left corner of the square and
finish selection.

f—»
d) Rename the group and click on “OK” button.

Apply Fixed displacement
X Fixed displacement x

Fixed displacement y

Ux: |0
- lines
Group: BL_point

‘ &/ OK || % Cancel

¥ %, Select

PUC




Fixed displacement

5. Assign fixed displacement .
g) Select the bottom edge of the square and finish

e) Doble-click on the “Mechanical > Boundary selection.
conditions > Fixed displacement” condition.
- ¥ JJBoundary conditions
AT
P b © group: BL_point y
+ Concentrated loads
i 11 Pressure on lines ‘
f) On the resulting window, select fixed displacement *
in y direction. Click on “lines” and “Select” button. h) Rename the group and click on “OK” button.
pply Fixed displacement pply Fixed displacement
Fixed displacement x Fixed displacement x
X Fixed displacement y - 1 X Fixed displacement y
- : m h
2
points points
Group: = \Select- 3 Group: B_edge ¥ N Select
X Cancel ‘ /0K || % Cancel fad

<§> TECGRAF 19 PUC

PUC-RIO




Concentrated loads

6. Assign concentrated loads .
c) Select the top corners of the square and finish

a) Doble-click on the “Mechanical > Boundary selection.

conditions > Concentrated loads” condition. -
- 7 ) Boundary conditions
¥ /) Fixed displacement
- b @ group: BL_point
b~ @ group: B_edge y
P _m Pressure on lines x
b) On the resulting window, select fixed displacement c) Rename the group and click on “OK” button.

in x direction. Click on “Select” button.

Apply Concentrated loads Apply Concentrated loads

kN = Fx: |0 kN -

Fx: |0
Fy: |-100 - kN - Fy: |-100] kN i

Group: - \Select- Group: Loads - ¥ | % Select
X Conce B /K | [X Conce
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Solver options

b) On the resulting window, set the correct options

7. Set solver optlons for the solver. Click on “OK” button.

a) Doble-click on the “Mechanical > Solver options” Solver options
fl el d . Solver type: Static nonlinear -
v o Mechanical Mechanical tolerance: 1E-5
i @ Dimension: 2D
v 0 Info Maximum number of steps: |1
b ElE General Load predictor increment: |1
- b [ Element
v I~ Materials Maximum load increment: |1
D@ Concrete Maximum load: 1
- 7 @Parts —
- Increment strategy: cylindrical arc length >
b © group: Concrete
| < “J Boundary conditions lteration strategy: cylindrical arc length -
9 /) Fixed displacement Newton-Raphson mode:  full -
b @ group: BL_point Convergence criterion: load =

_ b @ group: B_edge
v + Concentrated loads
- b @ group: Loads Max number of iterations: 10

Max number of attempts: |5

“ [I1 Pressure on lines

Normal flow
O T |

b B9 Units Load adjusted step

‘ +” 0K ¥ Cancel ﬁ
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GeMA input files

8. Generate mesh and input files

a) Click on the “Mesh > Generate mesh...” option. b) Save the project in a directory of your choice.
For example:

@ GiD x64 Project: UNNAMED (GiD-GeMA/GeMA)
Files View Geometry Utllltles Data Mesh Calculate Help
O e 9 ‘ 'g; e 1-I-> | d lsjt"ﬂ:t'-'d'-':d : GAMy Drive\Models\GiD fiIes’\,GiD—GeMA\,Benchmarks\ZDMecExample.gid|
ructure
c@ L] ] Gel SemiStructured 4
Mechanical . . . . . .
2 || 4|7 Bueconicl Boundary layer i €@ This version is compatible with cloud storage services.
ﬁ ) ‘%ﬂlnfu Quadratic type »
G vEGenen Element type ’
) O - Mesh criteria
Q . - ~[JDescription: Mo Reset mesh data
)‘ E; S;D analysis type{ o s
o . un GeMA: No
— € ) Boemen * Genemtemesh.  cug |
\4__ . 9| Materials Era.semﬁh M T R Kk 2
™ b @ Concrete Edit mesh *| Remark 1 EEEEEEEEE emar
~ 3 v @Parts e The mesh must be T Tolearn how create the
‘\id 1 % & group: Concrete View mesh boundary generated for each ENEEEEEEE geometry and the mesh,
Q s - [ Material: Concre P = h in th EEEEEEREE see “Help > Tutorials...”
! '_j-; 5 [) Thickness: 0.1 m|  Mesh quality... change ”';b € q Y EEEEEEEEE in GiD menu
[_J ‘ET'fl;lBoundaryconditiom Mesh options from model group_s Of boundary ’ ﬁ
JBAZ < AfFixed disolacomen y conditions or partS. x
(N
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GeMA input files

8. Generate mesh and input files
c) Click on the “Calculate > Calculate” menu option.  €) GeMA input files was generated. To get them, go to

the project directory chosen in the step 8b.
@ GiD x64 Project: 2DMecExample (GiD GeMA/GeMA)

Files View Geometry Utilities Data Mesh Calculate Help

0© thﬁ'\:_q{aléﬁ

D ZDMecExample.geo
H' ZDMecExamplelua

Calculate remote

» e 1 GeMA T | 2DMecExample.msh
Lancel process
&/ lZ v & Mechanical W View process info... @ 2DMecExample.png
B Dimension: 2D Calculate window... D 2DMecExample.prj

Y o & + 0 Info T
D ZDMecExample.rdr

D ZDMecExample.spd

- g . . . PP
d) In the notification window, click on “Ok” button. (] 2DMecExample.ree
D ZDMecExamplevv
@ Warning — Ol d 1/ 2DMecExample_model.lua

H' ZDMecExample_solution.lua

9 Input files generated with success!
Analysis was not performed.

Ok
= fat
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Run GeMA

9. Run GeMA

a) To enable this option, double-click on “Mechanical

> Info > General > Run GeMA” field.
v &} Mechanical
“ [@ Dimension: 2D
v O nfo
P v [EE General
- i~[] Description: Model generated with GiD-GeMA
() 2D analysis type: Plane strain

L™ (M Run GeMA: No =

b [E5] Element

b) Select “Yes” in the drop-down list.

7 {3 Mechanical
- @ Dimension: 2D
‘? © nfo
: = [E[E General
- i Description: Model generated with GiD-GeMA
(] 2D analysis type: Plane strain
- Oe N
b nEleo
v I Mote/ VST

J-‘.- TECGRAF
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as in step 8c.

c) Click on the “Calculate > Calculate” menu option,

d) GeMA output files was generated. To get them, go

to the project directory chosen in the step 8b.

out

| | 2DMeckxample.geo

H' 2DMecExample.lua

D 2DMecExample.msh

@ 2DMecExample.png

D 2DMecExample.prj

D 2DMecExample.rdr

D 2DMecExample.spd

D 2DMecExample.tree

D 2DMecExamplevv

H' 2DMecExample_model.lua
i/ 2DMecExample solutionlua

runlog.txt

Folder with output files

Log with run information

fat
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Calculate window

10.Run GeMA (calculate window)

a) Be sure the field "Run GeMA" is equal "Yes". c) In process window, click on the “Start” button.

- Mechanical . . . .
| ?n Dimension: 20 d) To follow the process info in real time, click on
v @info “Output view” button.
‘? E[E General :
- [ Description: Model generated with GiD-GeMA Process window n
Dl D ’"“""“p” Plane strain . Project Starttime UID Priority
b (3] Element

b) Click on the “Calculate > Calculate window...
menu option.

@ GiD x64 Project: 2DMecExample (GiD-GeMA\GeMA)
Files View Geometry Utilities Data Mesh Calculate Help =
Owglr\ﬁ“”*{*léﬁacmculme F5 2 |1 4
- Calculate remote . .
ﬁ ® Q GeMA ) , ~0u‘tput view Terminate
Cancel process
» IZ Y 0;’:“"‘“‘ s W View process info... 1 ‘ Start Start remote  Remote... Close
imension: Calculate window..,
Qb] = = A Infn —— 7 -
e) Find the output files as in step 9d. ﬁ
A
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Some tips

« Whenever you assign any new boundary condition (fixed displacement,

concentrated loads, etc.) make sure to generate the mesh again. This is an
action required by GID.

 If you find any bug, please follow these steps:
1. Save your work and close GIiD.
2. Reopen the model and try again.
3. Report to us all steps to reproduce error.
« To report any bug:
— Create an issue; or
— Send an e-mail.

J‘;-.;

TECGRAF 27 PUC
PUC-RIO RIO


https://git.tecgraf.puc-rio.br/gema/GiD2GeMA.gid/-/issues

‘l\
‘U.l; Contact

TECGRAF Francisco Dias - fcdiass@tecgraf.puc-rio.br
PUC-RIO Thiago Perry - tvperry@tecgraf.puc-rio.br
Cristian Mejia - crisms@tecgraf.puc-rio.br
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